-Selbstbau Computer - NDR- Klein-Computer (RDK) - Z80 and more
Registrieren | FAQ | Suche | Wer ist online? | Mitgliederliste | Heutige Beiträge | Einloggen



Autor Thema: 74HCT245 schwingt
m.haardt
Stammgast
**
ID # 93


  Erstellt am 27. April 2017 20:43 (#1)  |  Zitat Zitat   PN PN   E-Mail E-Mail
Hallo,

nach längerer Fehlersuche habe ich ein Problem gefunden, was ich so noch nicht kannte: Kurz gesagt wird ein 74HCT245 auf einer IO Karte 30 ns bevor ein Baustein auf der Karte den internen Bus der Karte treibt, aktiviert. Gerade, als der Baustein seine Daten auf den Bus legt, schwingt der 74HCT245 kurz und so heftig, dass er Spikes auf dem ganzen Board produziert. Das passiert sowohl auf einem Board von Hans-Werner als auch bei mir.

Nun soll man Eingänge von HCT nicht offen lassen, und tristate zählt wohl als offen, aber ich habe nicht erwartet, dass 30 ns schon für Ärger reichen. Die Schaltung vom Rest ist auch nicht ungewöhnlich, d.h. dieses Problem könnte verbreiteter sein, als man denkt.

Insbesondere kann es dazu führen, das kurz die falschen Chipselects aktiv werden, was z.B. bei Interruptstatusregistern, die durch Lesen gelöscht werden, sehr dumm endet.

Bei Bestückung mit LS Bausteinen gibt es das Problem nicht.

Hat jemand schon mal sowas gesehen?

Michael

Beiträge: 269 | Mitglied seit: April 2008 | IP-Adresse: gespeichert
m.haardt
Stammgast
**
ID # 93


  Erstellt am 30. April 2017 19:19 (#2)  |  Zitat Zitat   PN PN   E-Mail E-Mail
Wie's scheint, ist das eher unbekannt.

Ich habe inzwischen zwei Dinge probiert:

1. Das Enable des Bustreibern mit Gattern zu verzögern. Das ist wegen eines Designproblems der Z80 CPU Karte beim NKC sowieso empfehlenswert. Es zeigte sich, dass das Problem mit zwei Gattern schon deutlich verringert wird, aber ich sah auch, dass die Gatterlaufzeiten deutlich von dem Wert im Datenblatt abwichen. Das ist also keine sichere Lösung.

2. 8x10k Pullup-Widerstände auf dem internen Datenbus der Karte. Das funktioniert korrekt.

Es ist anzunehmen, dass dieses Problem beim Einsatz eines 74HCT245 auf anderen Karten beim NKC ebenfalls auftreten könnte. Wer diese also nicht umbauen will, sollte beim 74LS245 bleiben. Für neue Designs schlage ich die Pullups auch für LS vor, denn offene Eingänge sind nie gut.

Michael

Beiträge: 269 | Mitglied seit: April 2008 | IP-Adresse: gespeichert
hschuetz
Administrator
Seitenadmins
******
ID # 3


  Erstellt am 11. November 2017 22:23 (#3)  |  Zitat Zitat   PN PN   E-Mail E-Mail   HP HP
Hallo,
also größte Vorsicht mit den 74HCT245ern am Datenbus... anscheinend sind die HCT's absolut ungeeignet auf dem NKC.
Ich hatte mehrere merkwürdige Probleme... alle durch HCT's ausgelöst... LS Type rein und alles ok.
Gruß
Hans-Werner

-----------------------
Ob 8bit oder 16 oder 32 ist doch egal, Haupsache selbstgebaut!

Beiträge: 657 | Mitglied seit: Juni 2004 | IP-Adresse: gespeichert
Creep
Stammgast
**
ID # 169


  Erstellt am 13. November 2017 22:19 (#4)  |  Zitat Zitat   PN PN   E-Mail E-Mail
Hallo Hans-Werner,

kannst Du das Problem evtl. eingrenzen? Z.B., ob es nur am BUS3 oder auch am (nicht erweitertem) BUS2 auftritt? Evtl. kommen hier schon die Leitungslängen am BUS und die nicht vorhandene Terminierung zum Tragen? Dem könnte man dann evtl. entgegenwirken.

Gruß, Rene

Beiträge: 244 | Mitglied seit: Januar 2017 | IP-Adresse: gespeichert
hschuetz
Administrator
Seitenadmins
******
ID # 3


  Erstellt am 14. November 2017 07:34 (#5)  |  Zitat Zitat   PN PN   E-Mail E-Mail   HP HP
Hallo Rene,
das ist sicherlich nicht der BUS, da bei mir das auch mit intern terminierten Datenbus passierte. Anscheinend sind diese Bauteile nicht für den Zusammenspiel mit den LS Typen geeignet... es geht teilweise und dann mal wieder nicht...
also ein unsteter Fehler.
Mein Tipp, LS Typen am BUS nutzen
Gruß
Hans-Werner

-----------------------
Ob 8bit oder 16 oder 32 ist doch egal, Haupsache selbstgebaut!

Beiträge: 657 | Mitglied seit: Juni 2004 | IP-Adresse: gespeichert
m.haardt
Stammgast
**
ID # 93


  Erstellt am 15. November 2017 22:26 (#6)  |  Zitat Zitat   PN PN   E-Mail E-Mail
Das Problem sind schwingende Treiber, wenn sie aktiviert werden, ohne dass jemand die Eingänge treibt. Es dauert nicht lange. Leider sind viele Designs in dem Punkt schlampig, was bei LS nicht auffällt, weil deren Eingänge interne Pullups haben. Wenn der interne Bus nicht lang ist, kommt man mit externen 10k Pullups hin.

Michael

Beiträge: 269 | Mitglied seit: April 2008 | IP-Adresse: gespeichert
hschuetz
Administrator
Seitenadmins
******
ID # 3


  Erstellt am 17. November 2017 09:07 (#7)  |  Zitat Zitat   PN PN   E-Mail E-Mail   HP HP
Hallo,
leider auch nicht Michael, bei mir war es ausgerechnet an unserer SDIO das Problem...lief mal und mal nicht, anscheinend werden die HCT's beschädigt im NKC.
Gruß
Hans-Werner

-----------------------
Ob 8bit oder 16 oder 32 ist doch egal, Haupsache selbstgebaut!

Beiträge: 657 | Mitglied seit: Juni 2004 | IP-Adresse: gespeichert



| NKC Forum | Boardregeln


Tritanium Bulletin Board 1.6
© 2010–2016 Tritanium Scripts


Seite in 0,133400 Sekunden erstellt
18 Dateien verarbeitet
gzip Komprimierung ausgeschaltet
2488,11 KiB Speichernutzung